好顺手指点:股市公式是怎么壹回事?

股价打破开5日均线选股:

var1:=ma(c,5);

CROSS(c,var1);

同时给你壹些小目的,却在编纂目的时参考,祝君在股市中父亲发!

小目的公式编码集儿子合(壹)

供以下日用语句子,以便宜对象们编写公式时参考运用:

1)今收盘关于N日内最低收盘价的上涨幅(%)(c-llv(c,n))/llv(c,n)*100;

2)今收盘价关于N日最高收盘价的跌幅(%)(HHV(C,N)-C)/HHV(C,N)*100;

3)股价在度过去N日内运转当空的对立位置(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;

4)股价上方N1%到N2%处的筹(%)

aa:=winner(c+c*n2/100)*100;

bb:=winner(c+c*n1/100)*100;

aa-bb

5)股价下方N1%到N2%处的筹(%)

(winner(c-c*n1/100)-winner(c-c*n2/100))*100;

6)收盘价N%处的套牢盘100-(winner(c*N/100))*100;

7)收盘价N%处的利市盘winner(c*N/100)*100;

8)下影线(MIN(O,C)-L)/L*100;

9)上影线(h-max(o,c))/max(o,c)*100;

10)本周期的上涨跌幅(c-ref(c,1))/ref(c,1)*100;

11)振幅(h-l)/l*100;

12)均线金叉(M。

N为均线周期)cross(ma(c,m),ma(c,n))

13)均线多头老列

a1:=ma(c,n1);

a2:=ma(c,n2);

a3:=ma(c,n3);

a4:=ma(c,n4);

count(a1a2anda2a3anda3a4,3);

14)均线空头老列

a1:=ma(c,n1);

a2:=ma(c,n2);

a3:=ma(c,n3);

a4:=ma(c,n4);

count(a1a2anda2a3anda3a4,3);

15)N日均线向下

aa:=ma(c,n);

bb:=ref(aa,2);

aabb

16)前进N日到M日出产即兴度过均线死叉(P1P2)

aa:=ma(c,p1);

bb:=ma(c,p2);

cc:=ref(cross(bb,aa),n);

count(cc,m);

17)往昔日成提交量父亲于N日以后到的均量VOLMA(VOL,N);

18)低位稠麇集儿子

A1:=COST(85);

A2:=COST(15);

A3:=A1-A2;

A4:=(A1+A2)/2;

A5:=A3/A4*100

B1:=HHV(H,120);

B2:=LLV(L,120);

B3:=B1-B2;

B4:=(A4-B2)B3/2;

A5ANDB4;

19)换顺手比值VOL/CAPITAL*100;

20)N日载短

V1:=VOL/SUM(VOL,N);

V2:=DMA(CLOSE,V1);

V3:(CLOSE-V2)/V2*100;

21)强大势整顿理

{参数M、N区别代表周期和幅度m:1202n:1205}

a1:=abs(close-open)/open0。

015;

a2:=count(a1,m)=m;

a3:=ref(o,m)ref(close,m)and

ref(close,m)/ref(close,m+1)1+n/100;

a2anda3

22)高开父亲阴

{参数m,n区别代表幅度m:1104n:1205}

OPENCLOSEANDOPEN/REF(C,1)=1+M/100ANDCLOSE/OPEN=1-N/100

23)低开父亲阳线

{参数m,n区别代表幅度m:1104n:1207}

OPENCLOSEANDOPEN/REF(C,1)=1+N/100

壹、充分、收缩量(成提交量函数为VOL)

1、充分:

(1)。

皓天成提交量较昨天添加以了1倍,体即兴如次:

VOL/REF(VOL,1)2

(2)。

皓天成提交量较10个买进卖日平分成提交量收压缩制紧缩了1倍,体即兴如次:

a:=ma(vol,10);

Vol/a2

容许直接用如次公式体即兴:

vol/ma(vol,10)

(3)。

往昔日的5日均量较10个买进卖日平分成提交量收压缩制紧缩了1倍,体即兴如次:

a:=ma(vol,10);

b:=ma(vol,5);

b/a

(4)。

往昔日的成提交量超越了整顿个流动畅通盘的5%,体即兴如次:

vol/capital0。

05;就中capital代表流动畅通盘。

2、收缩量

(1)。

往昔日成提交量较昨日增添以了壹半,体即兴如次:

vol/ref(vol,1)0。

5;

(2)。

往昔日成提交量较10个买进卖日平分成提交量增添以壹倍,体即兴如次:

a:=ma(vol,10);

vol/a

容许直接用如次公式体即兴:

vol/ma(vol,10)

(3)。

往昔日的5日均量较10个买进卖日平分成提交量增添以1倍,体即兴如次:

a:=ma(vol,10);

b:=ref(a,5);

a/b

(4)。

往昔日的成提交量低于了整顿个流动畅通盘的5%,体即兴如次:

vol/capital0。

05;

二、下跌、下跌

下跌:

皓天的上涨幅到臻5%以上,体即兴如次:

close/ref(close,1)1。

05;

5日均价就续下跌,体即兴如次:

a:=ma(close,5);

b:=ref(a,1);

b;

下跌:

皓天的跌幅到臻5%以上,体即兴如次:

close/ref(close,1)0。

95;

5日均价就续下跌,体即兴如次:

a:=ma(close,5);

b:=ref(a,1);

(3)、K线的描绘

closeopen;阳线

closeopen;阴线

openref(close,1);高开

openref(close,1);低开

openref(high,1);跳空高开(high为最低价)

openref(low,1);跳空低开(low为最低价)

叁、走势特点选股公式的编制

(1)、n日内花样翻新高

hhv(high,n)=hhv(high,0)andbarscount(c)

注:n为目的参数,却在参数设定范畴内设定参数范畴。

Hhv(x,n),寻求n周期内x最高值,n=0则从第壹个拥有效值末了尾;barscount(x),将以后位置到n周期前的数值设为1,若x匪0,则将以后位置到n周期前的数值设为1。

(2)、n日内花样翻新低

llv(low,n)=llv(low,0)andbarscount(close)

注n为目的参数,却在参数设定范畴内设定参数范畴。

Llv(x,n),寻求n周期内x最低值,n=0则从第壹个拥有效值末了尾;barscount(x)第壹个拥有效数据到以后的天数,比如,barscount(close)以于日线数据得到上市以后到尽买进卖日数。

(3)、n日内阴线多于阳线

count(openclose,n)/n0。

5;

注:n为目的参数,却在参数设定范畴内设定参数范畴。

同时却以己在编纂外面面的数值(如0。

5等,到臻决定阴线占整顿个K线个数的比例)。

(4)、n日内阳线多于阴线

count(open0。

5;

注:n为目的参数,却在参数设定范畴内设定参数范畴。

同时却以己在编纂外面面的数值(如0。

5等,到臻决定阳线占整顿个K线个数的比例)。

(5)、n日内下跌多于下跌(第二天收盘高于前壹天收盘)

count(cref(c,1),n)/n0。

5;

注:n为目的参数,却在参数设定范畴内设定参数范畴。

同时却以己在编纂外面面的数值(如0。

5等,到臻决定就中比例)。

(6)、n日内下跌微少于下跌(第二天收盘低于前壹天收盘)

count(cref(c,1),n)/n0。

5;

注:n为目的参数,却在参数设定范畴内设定参数范畴。

同时却以己在编纂外面面的数值(如0。

5等,到臻决定就中比例)。

(7)、就续n日收阳线

up:=closeopen;

count(up,n)=n;

注:count(x,n),统计n周期中满意x环境的周期数,若n=0则从第壹个拥有效值末了尾。

n为目的参数,却在参数设定范畴内设定参数范畴。

(8)、就续n日内收阴线

up:=closeopen;

count(up,n)=n;

注:count(x,n),统计n周期中满意x环境的周期数,若n=0则从第壹个拥有效值末了尾。

N为目的参数,却在参数设定范畴内设定参数范畴。

(9)、就续n天下跌

count(closeref(close,1),n)=n;

注:count(x,n),统计n周期中满意x环境的周期数,若n=0则从第壹个拥有效值末了尾。

N为目的参数,却在参数设定范畴内设定参数范畴。

(10)、就续n天下跌

count(cref(c,1),n)=n;

注:count(x,n),统计n周期中满意x环境的周期数,若n=0则从第壹个拥有效值末了尾。

N为目的参数,却在参数设定范畴内设定参数范畴。

(11)、初次花样翻新高

barssince(chhv(if(barscount(c)=1,high,0),0))+1=1;

注:barscount(x),若x匪0,则将以后位置到n周期前的数值设为1。

(12)、创历史新高

hhv(close,0)=close;

注:hhv(x,n),寻求n周期内x最高值,n=0则从第壹个拥有效值末了尾。

(13)、创历史新低

llv(close,0)=close;

注:llv(x,n),寻求n周期内x最小值,n=0则从第壹个拥有效值末了尾。

(14)、单日充分

a:=ref(ma(vol,5),1);

vol/anandvol/capital*100

注:n为目的参数,代表往昔日成提交量和前壹日的5日均量的比值,却在参数设定范畴内设定参数范畴。

(15)、阶段收缩量

sum(vol,n1)/capital=n2;

注:n1为要统计的阶段时间,n2为收缩量比例,却在参数设定范畴内设定参数范畴。

(16)、阶段充分

sum(vol,n1)/capital=n2;

注:n1为要统计的阶段时间,n2为y充分比例,却在参数设定范畴内设定参数范畴。

(17)、持续充分

a:=volref(vol,1);

count(a,n)=n;

注:就中环境a的含义为成提交量较上壹买进卖日收压缩制紧缩,n为要统计的阶段时间,却在参数设定范畴内设定参数范畴。

(18)、持续收缩量

a:=volref(vol,1);

count(a,n)=n;

注:就中环境a的含义为成提交量较上壹买进卖日增添以,n为要统计的阶段时间,却在参数设定范畴内设定参数范畴。

(19)、距退充分

a:=ma(vol,5);

barscount(c)=nandhhv(a,n)n2*a,n)

注:a。

barscount(x)第壹个拥有效数据到以后的天数。

Barscount(c)关于日线数据得到上市以后到尽买进卖日数。

b。

完整顿含义:n日内五日均量的最父亲值小于最小值的n1倍,成提交量父亲于等于五日均量的n2倍的情景突发的次数多于n3次。

(20)、充分上攻

a:=(c-ref(c,1))/ref(c,1)=(n/100);

sum(vol,n1)/capital=(n2/100)andcount(volref(vol,1),n3)=n3andcount(a,n3)=n3;

完整顿含义:每日股价上涨幅均父亲于n%,n1日内累计换顺手比值父亲于n2%,同时成提交量就续在n3日内收压缩制紧缩。

(21)、装置然装置祥充分上攻

股价小幅上扬

a1:=close/ref(close,1);

a2:=a11anda11。

03;

成提交量小幅上扬

b1:=vol/ref(vol,1);

b2:=b11andb1

c1:=ma(vol,n)/capital0。

05;

count(a2andb2,n)/n0。

6andc1;

完整顿公式为:

a1:=close/ref(close,1);

a2:=a11anda11。

03;

b1:=vol/ref(vol,1);

b2:=b11andb1

c1:=ma(vol,n)/capital0。

05;

count(a2andb2,n)/n0。

6andc1;

注:公式分为股价小幅上扬和成提交量小幅上扬两个片断,请在目的编写时剩意其构造。

(22)、忽然充分

volref(hhv(vol,n),1*m;

注:以后成提交量高于n个周期中最父亲成提交量的m倍。

(23)、平台整顿理

count(close,0)nand(hhv(close,n)-llv(close,n))/llv(close,n)=(n1/100);

注:count(close,0)n为平台整顿理n个周期的设定。

(hhv(close,n)-llv(close,n))/llv(close,n)=(n1/100)为平台整顿理幅度n1%的设定。

(24)、打破开临时盘整顿

ref(((hhv(h,n)-llv(l,n))/llv(l,n))/llv(l,n)),1)=ref(hhv(h,n),1)andbarscount(c)

注:前n日在左右n1%的幅度内整顿理:ref(((hhv(h,n)-llv(l,n))/llv(l,n))/llv(l,n)),1)=(n1/100);

往昔日打破开:c=ref(hhv(h,n),1)。

(25)、阶段强大势股

a:=sum(if(date-n=0,indexc,0),0);

b:=sum(if(date-n1=0,indexc,0)0);

e:=sum(if(date-n=0,c,0),0);

f:=sum(if(date-n1=0,c,0),0);

((f-e)/e)((b-a)/a);

注:该公式寻求的是n日-n1日之间上涨幅高于父亲盘的股票。

n、n1参数的表臻程式为yymmdd,剩意在2000年前的表臻为年份的后两位,比如1999年为99,从2000岁末了尾以100以次向后累加以,比如2001年9月14日为1010914,indexc函数体即兴同期父亲盘的收盘价,该函数对分笔成提交剖析周期拥有效。

(26)、阶段绵软弱势股

a:=sum(if(date=n,indexc,0),0);

b:=sum(if(date=n1,indexc,0)0);

e:=sum(if(date=n,c,0),0);

f:=sum(if(date=n1,c,0),0);

((f-e)/e)((b-a)/a);

注:该公式寻求的是n日-n1日之间上涨幅低于父亲盘的股票。

n、n1参数的表臻程式为yymmdd,剩意在2000年前的表臻为年份的后两位,比如1999年为99,从2000岁末了尾以100以次向后累加以,比如2001年9月14日为1010914,indexc函数体即兴同期父亲盘的收盘价,该函数对分笔成提交剖析周期拥有效。

哈哈哈哈,看看写了此雕刻么多,此雕刻些东方正西邑是给基金经纪们看的,我们根本不用看,看了也没拥有用。


bck体育手机版官网下载_bckbet下载_bck体育信得过吗